In diesem video zeige Ich euch, wie Ihr euere Nextcloud auf die Version 21 aktualisieren könnt und auch alle damit verbundenen Fehlermeldungen beheben könnt!

» Nextcloud 21 Upgrade Videos:
MariaDB aktualisieren: https://youtu.be/x9nST2QKa9M
PHP 8.0 installieren: https://youtu.be/7WmifSHQ3SI

» Folgende Fehler werden in diesem Video behandelt:
Für deine Installation ist keine Standart-Telefonregion festgelegt. Dies ist erforderlich, um Telefonnummern in den Profileinstellungen ohne Ländercode überprüfen zu können. Um Nummern ohne Ländercode zuzulassen, fuge bitte „default_phone_region“ mit dem entsprechenden ISO 3166-1-Code der gewünschten Region hinzu.

In der Datenbank fehlen einige Indizes. Auf Grund der Tatsache, dass das Hinzufügen von Indizes in großen Tabellen einige Zeit in Anspruch nehmen kann, wurden diese nicht automatisch erzeugt. Durch das Ausfuhren von “occ db:add-missing-indices“ konnen die fehlenden Indizes manuell hinzugefügt werden, wahrend die Instanz weiter lauft. Nachdem die Indizes hinzugefügt wurden, sind Anfragen auf die Tabellen normalerweise schneller.

Dem Modul php-imagick fehlt die SVG-Unterstiitzung. Für eine bessere Kompatibilität wird empfohlen, es zu installieren.



### Nextcloud V21 Upgrade ###

## upgrade Nextcloud ##
sudo -u www-data php occ upgrade

sudo -u www-data php occ maintenance:mode --off

#1 Standart Telefonregion

## open nextcloud config.php
nano /var/www/nextcloud/config/config.php

add:
'default_phone_region' => 'DE',

#2 php-imagick fehlt die SVG-Unterstützung

## install libmagickcore-6.q16-6-extra ##

apt update 
apt install libmagickcore-6.q16-6-extra

 

apfelcast Support

Du benötigst Unterstützung bei deinem Projekt oder hast Fragen zur Umsetzung?
Dann melde ich gern bei uns!

Kontaktieren